Jump to content
Shawn

Upgrade to 3 in progress

Recommended Posts

Here is a shot of the old forums (running locally on my computer now)

We are kind of close. Still have to fix some of the blues, and the headers. But mostly there....

S

post-10-127396659393_thumb.jpg

Share this post


Link to post
Share on other sites

i love the new board look! thank you

Share this post


Link to post
Share on other sites

Ok-I think I have fixed everything in the forums. if you see something very low contrast, or a missing image, please let me know.

Tomorrow I'll find some time to fix the gallery-I see its missing some items.

S

Share this post


Link to post
Share on other sites

The "current page number" in a topic, is blue on blue. This very topic is an example---I'm on page 2, yet you can only see the '1' and the arrow.

Share this post


Link to post
Share on other sites

Have quotes in older posts been messed up? They seem to have lost their frames and links:

QUOTE (Penguin @ May 6 2010, 08:58 AM)Normally I don't prime, but due to the darker grey plastic I did a coat of white primer for my fan racer. Helps the orange/red stand out without having to layer it on too thick. I recommend Tamiya's paints too. My little fan racer is all Tamiya except for a little fine marker work on the panel lines and Hikaru... flat white primer, gloss white, medium grey, orange, flat black, and flat aluminum for the plane, then orange, yellow, flesh, semi-gloss black, and sky blue for Hikaru.

Thanks guys!!

Share this post


Link to post
Share on other sites

Fixed

The "current page number" in a topic, is blue on blue. This very topic is an example---I'm on page 2, yet you can only see the '1' and the arrow.

Share this post


Link to post
Share on other sites

I'll need to see if other boards had this problem on conversion as well, and if there is script we can write to fix.

Have quotes in older posts been messed up? They seem to have lost their frames and links:

Share this post


Link to post
Share on other sites
Graham-in the bottom left is an option to view the forums in low-res mode-perhaps your phone would prefer that?

On a side note, while checking the forums with my iPhone, it automatically defaulted to the Lo-Fi skin without needing to login or changing anything (and with a nice little message at the bottom of the page). I'm not sure how it is for other mobile browsers.

post-15-127402951464_thumb.jpg

Share this post


Link to post
Share on other sites

On a side note, while checking the forums with my iPhone, it automatically defaulted to the Lo-Fi skin without needing to login or changing anything (and with a nice little message at the bottom of the page). I'm not sure how it is for other mobile browsers.

I logged in from both my Palm Pre and HTC Hero and both had the regular forum skin, neither defaulted to Lo-Fi. If needed I can try logging in from Opera-Mini.

-b.

Edited by Kanedas Bike

Share this post


Link to post
Share on other sites

Great work so far Shawn. The new site looks and functions great. I am so glad that you got the skin back. The generic skin after the change over had me sad and missing the old one. Now the new one is looking better than the old one. So thanks again!

Share this post


Link to post
Share on other sites

i love the threaded conversations in PM... saves you from having to remember to save sent messages.

I also like the fact that when you post image attachments now, it allows you to go from one image to another, gallery style, so we don't have to click on the individual thumbnails.

Love the new boards.

Share this post


Link to post
Share on other sites

The Lo-Fi skin is worse if anything. It also crashes my phone's web browser and doesn't even display correctly. Just a grey screen, with a garbled string of text down the left side of the screen.

The MW skin 3.0 displays correctly, but will always crash my phone. If I'm lucky, I get to look at one thread before it crashes.

As I mentioned before, I do use my phone a lot for web-browsing, but have never encountered this problem with any other website or forum. Weird!

Home PC is down for the moment and have limited time at work to browse MW. :(

May not be around here too much until I can persuade the wife we need to buy a new home PC.

Graham (from work)

Share this post


Link to post
Share on other sites
Graham---is your phone itself updated, software/browser-wise?

More to the point...which phone are you using Graham?

Share this post


Link to post
Share on other sites

I can see the new skin on my iPhone now.

Share this post


Link to post
Share on other sites

I will enable the default IB skin. Perhaps you can try that Graham?

It currently outputs as XML

if that fails, we can adjust it to export html

let me know

S

Share this post


Link to post
Share on other sites

Minor backburner type request, but where's the back to top button. I finally started using that.

Share this post


Link to post
Share on other sites

I really like the new board so far, but do miss a couple things.

-Links used to open in a new tab

-The forum switch scroll through deally used to automatically load the selected forum without having to click "go"

-Everyone's interests are showing their entire list of interests, which is quite long for some members.

Aside from that, digging the new design.

Share this post


Link to post
Share on other sites

-Links used to open in a new tab

This I can answer.

Brandon Farber of Invision states this:

Proper standards for "today's web" state that you shouldn't dictate to a user how the link opens. The user can already control this themself by ctrl+clicking, right click -> open in new window, middle clicking, and a number of other options. In fact, in XHTML Strict doctype (which we use) there is no "target" attribute for the anchor tag anymore, so the specifications don't even *allow* you to control this.

Our setting resorts to a javascript method that can be added elsewhere if needed. Realistically, though, your members should be left to make this decision on their own imo.

Share this post


Link to post
Share on other sites

This I can answer.

Brandon Farber of Invision states this:

That's what I figured, and yet it totally fly's in the face of my futuristic entitled lazy ass :)

Share this post


Link to post
Share on other sites

Wow. Am gone for awhile and we have a new board. I like it so far, but feel I'am going to have get use it. Still I love it. ^_^

Edited by SkullLeaderVF-X

Share this post


Link to post
Share on other sites

Can we kill the "interests" display yet on posts? I'm seeing more and more super-long ones. I'd rather not have to have everyone re-do theirs to like a 10-word maximum.

Share this post


Link to post
Share on other sites

The new boards look great! Bravo!

I do miss two things (treat them as suggestions or what not...)

1. Could the What's New / Active Threads be placed back up at the top so you don't have to go to the bottom of the page to get it?

2. This is really old, I loved how the old, old, boards you could attach images inline with your thread and post it to the MW servers, I used to love to post images of my in-progress builds and comment under each image - now I can only upload a bunch of image at the end of the text which appears as a bunch of random thumbnails (or I can attach a link to some place to host my images, which I rather not).

Lastly not so much something I miss, but is there a colour theme that is less "colourful"... I like to check in from work from time to time, but its so obvious that it's a website. If it was in shades of grey, then it just blends into all my other open windows on my desktop. ;-)

Just my 2 cents, great job on the upgrade though!

Thanks for all your hard work and effort, its muchly appreciated here.

Edited by wm cheng

Share this post


Link to post
Share on other sites

Lastly not so much something I miss, but is there a colour theme that is less "colourful"... I like to check in from work from time to time, but its so obvious that it's a website. If it was in shades of grey, then it just blends into all my other open windows on my desktop. ;-)

You can use the Lo-Fi skin. At the bottom of each page, you can select a different skin to use.

Share this post


Link to post
Share on other sites

Am I the only one that has click "edit" twice, to edit? Or am I the only one complaining about it?

::edit:: Ok, that's ironic, for the first time ever, it worked on the first click...

Share this post


Link to post
Share on other sites

Finally persuaded the wife that we need a new PC for the home. My last one was about 7-8 years old (at least) and was on its last legs and was so slow with the new forum software.

Still not happy that the new forum software crashes my phone's web browser though. BTW, my phone is a Nokia 5320. FaceBook, Gmail, many other other websites and forums all run fine on my phone. MW is the only one that crashes it.

I'm a "if it ain't broke, don't fix it" kinda guy, so still don't see why this forum software change (I refuse to call it an upgrade), was necessary.....grumble, grumble, grumble.

Just cus' something's new, don't necessarily make it better!

Graham

Share this post


Link to post
Share on other sites

I'm a "if it ain't broke, don't fix it" kinda guy, so still don't see why this forum software change (I refuse to call it an upgrade), was necessary.....grumble, grumble, grumble.

Just cus' something's new, don't necessarily make it better!

I agree. There's another website that I frequent that not only decided an upgrade was due (when it wasn't), they also redesigned it to cater specifically for the i-toy market (which constitutes anywhere from 2.2 to 5.0% of that website's users!)

On the other hand, it was to my understanding that there were problems with the previous software used for this site - I haven't heard of any connectivity issues since the upgrade. So, in some part, this update was necessary. That said, the changes in the update itself were unnecessary. (TBH, I've found it a bit more confusing, and the colour codes - much improved with the custom ones - are too washed out and "bright".)

The upgrade also does appear to take a bit longer to download; implying that there is more code needed to do the same actions. Maybe that's what's crashing the phone? Too much and/or incompatible code?

Share this post


Link to post
Share on other sites

Finally persuaded the wife that we need a new PC for the home. My last one was about 7-8 years old (at least) and was on its last legs and was so slow with the new forum software.

Still not happy that the new forum software crashes my phone's web browser though. BTW, my phone is a Nokia 5320. FaceBook, Gmail, many other other websites and forums all run fine on my phone. MW is the only one that crashes it.

Have you tried Opera Mini/Opera Mobile for your phone? Or even Skyfire? I recall from my experience with the S60 browser on my olde S60 v3/FP2-based phone that it wasn't as well-equipped to handle things on the web that the former 2 could handle much better. I also heard that the S60 5th edition handles the web much better than the S60 3rd edition/FP2.

Share this post


Link to post
Share on other sites

Eventually, IPB 2.x wasn't going to be supported any longer with security updates. Better to do it now during a planned, methodical upgrade than do it in a rush a year from now when the site is un-updated, vulnerable, and under attack.

Share this post


Link to post
Share on other sites

Eventually, IPB 2.x wasn't going to be supported any longer with security updates. Better to do it now during a planned, methodical upgrade than do it in a rush a year from now when the site is un-updated, vulnerable, and under attack.

The company that I work for was on an old version of Joomla CMS and we lagged on upgrading for too long. Finally our site got hacked and hundreds of files were infected with Trojans and Viruses. It was embarrassing and expensive and we were freaking out for over a week trying to fix things. So I can see how it is smart to upgrade before things go wrong. I am glad that the upgrade went well and that nothing was lost! Thanks again for all of your hard work Shawn. Graham, Im sorry that you are still having trouble accessing the site. Hopefully your phone's software updates will solve the problem.

Share this post


Link to post
Share on other sites

Just a small thing, not sure if it's a personal setting issue or not but it would be nice if clicking on a link in a post opened a new page in the browser instead of going away from the forums to the new site.

Now that we've got a new forum how about updating the front site's main menu page. It has the last date for site updates & breaking news as 2nd June 2008. Could be scaring away a few potential members as I know if I end up on a front page that has the last site update nearly 2 years ago I usually don't bother going any further.

Share this post


Link to post
Share on other sites

This I can answer.

Brandon Farber of Invision states this:

OK... It's obvious I don't know how to use this feature...

Um, yeah. What I meant to say was check Azrael's post a page or so back, where he states the reason this so. Current web development suggests giving the user complete control over hyperlinks. Instead of forcing a new window on the user, give the user complete control over what they want to do. In this age of tabbed browsing, right clicking a link and choosing new window or new tab is an option, or if you have a mouse with a wheel (does anyone not?) you can middle click in most tabbed browsers (I've yet to find one that doesn't support this) and it will automatically open a new tab. I regularly browse sites this way. I'll be reading a web page and think as I'm going, "I must look into that later" so end up middle clicking. I routinely end up with 4 or 5 pages to look at after I've read the page. But that's just me...

Edited by mickyg

Share this post


Link to post
Share on other sites

OK... It's obvious I don't know how to use this feature...

Um, yeah. What I meant to say was check Azrael's post a page or so back, where he states the reason this so. Current web development suggests giving the user complete control over hyperlinks. Instead of forcing a new window on the user, give the user complete control over what they want to do. In this age of tabbed browsing, right clicking a link and choosing new window or new tab is an option, or if you have a mouse with a wheel (does anyone not?) you can middle click in most tabbed browsers (I've yet to find one that doesn't support this) and it will automatically open a new tab. I regularly browse sites this way. I'll be reading a web page and think as I'm going, "I must look into that later" so end up middle clicking. I routinely end up with 4 or 5 pages to look at after I've read the page. But that's just me...

Oh cool! thanks! That really helps! I was sitting here thinking... Screw this Brandon Farber guy!

Share this post


Link to post
Share on other sites

Yeah, sorry bout that. If someone can tell me how this "multi quote" option works, I'd feel much smarter! I couldn't figure out how to use it on the old forums either so maybe it's not an upgrade specific problem, just a user knowledge one...

Share this post


Link to post
Share on other sites

×