Jump to content
Sign in to follow this  
valiantknight

YF19 Leg Armor Problems

Recommended Posts

I recently got a fold booster set and have been having issues with the leg armor. When I put it on in fighter mode it doesn't stay in place correctly when you try to snap the wings into place on it. Is anyone else having this issue or am I doing something wrong.

VK

Share this post


Link to post
Share on other sites
I recently got a fold booster set and have been having issues with the leg armor. When I put it on in fighter mode it doesn't stay in place correctly when you try to snap the wings into place on it. Is anyone else having this issue or am I doing something wrong.

VK

Be aware of the position of the thigh joints. Look at the manual and you will see you need to "1 click down" on the upper thigh and "1 click up" on the joint below it. This means the legs are no longer in a straight position in fighter mode. The leg armor should be able to go in snugly if the right angle is done on the thigh joints.

Share this post


Link to post
Share on other sites

Also make sure the shoulder fastpacks are set propely in the leg. I was having some troubles with it until I realized I didn't have the shoulder fast packs set up properly.

The point that wolfx brought up is the other problem I had. Making sure that the legs are in the correct position.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×